$re = '/qw=([A-Za-z0-9]+)&pag=([0-9]+)/';
$str = '/Material/Index?qw=palavraChave&pag=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);