import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z][a-zA-Z0-9]*\\?? *(?:<.+>)?) [a-zA-Z]+";
final String string = "InitializeWith(\n"
+ " ScaleFactor scaleFactor,\n"
+ " int raster,\n"
+ " Action<IPresenceBarViewModel> highlightPresenceBar,\n"
+ " Action<IWorkBarViewModel> highlightWorkBar,\n"
+ " Action resetCellsInOtherDays,\n"
+ " Action selectDay,\n"
+ " Action unselectAllBars,\n"
+ " Action unselectAllWorkItems,\n"
+ " bool isWorkDay,\n"
+ " DateTime date,\n"
+ " Action<ICellViewModel> insertBarAtStartOfCell,\n"
+ " Action<TimeSpan, ICellViewModel> addBarAt,\n"
+ " Action<DateTime> alignPresenceBar,\n"
+ " Func<Employee> getTargetEmployee,\n"
+ " Func<ITimeRecordingProjectsNode> getTargetProject,\n"
+ " ITreeViewModel treeViewModel,\n"
+ " Func<TimeRecordingDaysAndAdditionalData> getTimeRecordingDaysAndAdditionalData,\n"
+ " Func<TimeSpan, ICellViewModel, TimeSpan> getBarStartTimeFor,\n"
+ " Func<DateTime, bool> canPresenceBarBeAligned,\n"
+ " Action<IBarViewModel> detectAndResolveBarCollisions,\n"
+ " Action checkAndRefreshDay,\n"
+ " Action<DateTime> changeSelectedTimeRecordingDayTo)";
final String subst = "It.IsAny<$1>()";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}