const regex = /([a-zA-Z][a-zA-Z0-9]*\?? *(?:<.+>)?) [a-zA-Z]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z][a-zA-Z0-9]*\\?? *(?:<.+>)?) [a-zA-Z]+', 'gm')
const str = `InitializeWith(
ScaleFactor scaleFactor,
int raster,
Action<IPresenceBarViewModel> highlightPresenceBar,
Action<IWorkBarViewModel> highlightWorkBar,
Action resetCellsInOtherDays,
Action selectDay,
Action unselectAllBars,
Action unselectAllWorkItems,
bool isWorkDay,
DateTime date,
Action<ICellViewModel> insertBarAtStartOfCell,
Action<TimeSpan, ICellViewModel> addBarAt,
Action<DateTime> alignPresenceBar,
Func<Employee> getTargetEmployee,
Func<ITimeRecordingProjectsNode> getTargetProject,
ITreeViewModel treeViewModel,
Func<TimeRecordingDaysAndAdditionalData> getTimeRecordingDaysAndAdditionalData,
Func<TimeSpan, ICellViewModel, TimeSpan> getBarStartTimeFor,
Func<DateTime, bool> canPresenceBarBeAligned,
Action<IBarViewModel> detectAndResolveBarCollisions,
Action checkAndRefreshDay,
Action<DateTime> changeSelectedTimeRecordingDayTo)`;
const subst = `It.IsAny<$1>()`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);