// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z][a-zA-Z0-9]*\?? *(?:<.+>)?) [a-zA-Z]+").unwrap();
let string = "InitializeWith(
ScaleFactor scaleFactor,
int raster,
Action<IPresenceBarViewModel> highlightPresenceBar,
Action<IWorkBarViewModel> highlightWorkBar,
Action resetCellsInOtherDays,
Action selectDay,
Action unselectAllBars,
Action unselectAllWorkItems,
bool isWorkDay,
DateTime date,
Action<ICellViewModel> insertBarAtStartOfCell,
Action<TimeSpan, ICellViewModel> addBarAt,
Action<DateTime> alignPresenceBar,
Func<Employee> getTargetEmployee,
Func<ITimeRecordingProjectsNode> getTargetProject,
ITreeViewModel treeViewModel,
Func<TimeRecordingDaysAndAdditionalData> getTimeRecordingDaysAndAdditionalData,
Func<TimeSpan, ICellViewModel, TimeSpan> getBarStartTimeFor,
Func<DateTime, bool> canPresenceBarBeAligned,
Action<IBarViewModel> detectAndResolveBarCollisions,
Action checkAndRefreshDay,
Action<DateTime> changeSelectedTimeRecordingDayTo)";
let substitution = "It.IsAny<$1>()";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}