$re = '/([a-zA-Z][a-zA-Z0-9]*\?? *(?:<.+>)?) [a-zA-Z]+/m';
$str = 'InitializeWith(
ScaleFactor scaleFactor,
int raster,
Action<IPresenceBarViewModel> highlightPresenceBar,
Action<IWorkBarViewModel> highlightWorkBar,
Action resetCellsInOtherDays,
Action selectDay,
Action unselectAllBars,
Action unselectAllWorkItems,
bool isWorkDay,
DateTime date,
Action<ICellViewModel> insertBarAtStartOfCell,
Action<TimeSpan, ICellViewModel> addBarAt,
Action<DateTime> alignPresenceBar,
Func<Employee> getTargetEmployee,
Func<ITimeRecordingProjectsNode> getTargetProject,
ITreeViewModel treeViewModel,
Func<TimeRecordingDaysAndAdditionalData> getTimeRecordingDaysAndAdditionalData,
Func<TimeSpan, ICellViewModel, TimeSpan> getBarStartTimeFor,
Func<DateTime, bool> canPresenceBarBeAligned,
Action<IBarViewModel> detectAndResolveBarCollisions,
Action checkAndRefreshDay,
Action<DateTime> changeSelectedTimeRecordingDayTo)';
$subst = "It.IsAny<$1>()";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;