#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*[^+0-9\\-]+$|^[^+0-9\\-]+.*$"
Local $sString = "+123-\" & @CRLF & _
"+232aa" & @CRLF & _
"asdad$" & @CRLF & _
"+331234-44" & @CRLF & _
"123asd" & @CRLF & _
"asdad123$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")