re = /^.*[^+0-9\\-]+$|^[^+0-9\\-]+.*$/m
str = '+123-\\
+232aa
asdad$
+331234-44
123asd
asdad123$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end