using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*[^+0-9\\-]+$|^[^+0-9\\-]+.*$";
string input = @"+123-\
+232aa
asdad$
+331234-44
123asd
asdad123$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}