import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*[^+0-9\\\\-]+$|^[^+0-9\\\\-]+.*$";
final String string = "+123-\\\n"
+ "+232aa\n"
+ "asdad$\n"
+ "+331234-44\n"
+ "123asd\n"
+ "asdad123$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}