using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(trans(?:_choice)?|Lang::(?:get|choice|trans(?:Choice)?)|@(?:lang|choice))\(([\'""]([^\'""]+)[\'""])[)\]];?";
string input = @"trans('email.subject')
@lang('email.confirm-email-address-button')
@lang('emails/order-received.edit-order-button')";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}