package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(trans(?:_choice)?|Lang::(?:get|choice|trans(?:Choice)?)|@(?:lang|choice))\(([\'"]([^\'"]+)[\'"])[)\]];?`)
var str = `trans('email.subject')
@lang('email.confirm-email-address-button')
@lang('emails/order-received.edit-order-button')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}