$re = '/(trans(?:_choice)?|Lang::(?:get|choice|trans(?:Choice)?)|@(?:lang|choice))\(([\'"]([^\'"]+)[\'"])[)\]];?/m';
$str = 'trans(\'email.subject\')
@lang(\'email.confirm-email-address-button\')
@lang(\'emails/order-received.edit-order-button\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);