re = /(trans(?:_choice)?|Lang::(?:get|choice|trans(?:Choice)?)|@(?:lang|choice))\(([\'"]([^\'"]+)[\'"])[)\]];?/m
str = 'trans(\'email.subject\')
@lang(\'email.confirm-email-address-button\')
@lang(\'emails/order-received.edit-order-button\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end