import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "OPTIONS=\\\"(?:(.*)(-u [a-z]+:[a-z]+))?(.*?)\\\"";
final String string = "OPTIONS=\"-x -u wrong:wrong -c blah\"\n"
+ "OPTIONS=\"-u wrong:wrong -x -c blah\"\n"
+ "OPTIONS=\"-x -c blah -u wrong:wrong\"\n"
+ "OPTIONS=\"-x -c blah\"";
final String subst = "OPTIONS=\"\\1 \\3 -u ntpd:ntpd\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}