package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)OPTIONS=\"(?:(.*?)(-u [a-z]+:[a-z]+))?(.*)\"`)
var str = `OPTIONS="-x -u wrong:wrong -c blah"
OPTIONS="-u wrong:wrong -x -c blah"
OPTIONS="-x -c blah -u wrong:wrong"
OPTIONS="-x -c blah"`
var substitution = "OPTIONS="\1 \3 -u ntpd:ntpd""
fmt.Println(re.ReplaceAllString(str, substitution))
}