import re
regex = re.compile(r"OPTIONS=\"(?:(.*?)(-u [a-z]+:[a-z]+))?(.*)\"", flags=re.MULTILINE)
test_str = ("OPTIONS=\"-x -u wrong:wrong -c blah\"\n"
"OPTIONS=\"-u wrong:wrong -x -c blah\"\n"
"OPTIONS=\"-x -c blah -u wrong:wrong\"\n"
"OPTIONS=\"-x -c blah\"")
subst = "OPTIONS=\"\\1 \\3 -u ntpd:ntpd\""
result = regex.sub(subst, test_str)
if result:
print(result)