const regex = new RegExp('OPTIONS=\\"(?:(.*?)(-u [a-z]+:[a-z]+))?(.*)\\"', 'gm')
const str = `OPTIONS="-x -u wrong:wrong -c blah"
OPTIONS="-u wrong:wrong -x -c blah"
OPTIONS="-x -c blah -u wrong:wrong"
OPTIONS="-x -c blah"`;
const subst = `OPTIONS="\1 \3 -u ntpd:ntpd"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);