$re = '/OPTIONS=\"(?:(.*?)(-u [a-z]+:[a-z]+))?(.*)\"/m';
$str = 'OPTIONS="-x -u wrong:wrong -c blah"
OPTIONS="-u wrong:wrong -x -c blah"
OPTIONS="-x -c blah -u wrong:wrong"
OPTIONS="-x -c blah"';
$subst = "OPTIONS=\"\1 \3 -u ntpd:ntpd\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;