package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\b[\d]+[.,]?\b)+`)
var str = `6,111,123,999 5,450,900 10.32 OCT21 Dec 31, 2019`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}