re = /(?:\b[\d]+[.,]?\b)+/m
str = '6,111,123,999 5,450,900 10.32 OCT21 Dec 31, 2019'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end