import re
regex = re.compile(r"(?:\b[\d]+[.,]?\b)+", flags=re.MULTILINE)
test_str = "6,111,123,999 5,450,900 10.32 OCT21 Dec 31, 2019"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")