package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^@\s]+@[^@\s]+\.[^@\s.]+;)+$`)
var str = `user1@xxx.com;
user1@xxx.com;user2@xxx.com;
user1@xxx.com;user2@xxx.com;user3@xxx.com;
user1@xxx.com
user1@xxx
user1@xxx.com;user2@xxx.com `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}