re = /^([^@\s]+@[^@\s]+\.[^@\s.]+;)+$/m
str = 'user1@xxx.com;
user1@xxx.com;user2@xxx.com;
user1@xxx.com;user2@xxx.com;user3@xxx.com;
user1@xxx.com
user1@xxx
user1@xxx.com;user2@xxx.com '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end