import re
regex = re.compile(r"^([^@\s]+@[^@\s]+\.[^@\s.]+;)+$", flags=re.MULTILINE)
test_str = ("user1@xxx.com;\n"
"user1@xxx.com;user2@xxx.com;\n"
"user1@xxx.com;user2@xxx.com;user3@xxx.com;\n\n"
"user1@xxx.com\n"
"user1@xxx\n"
"user1@xxx.com;user2@xxx.com ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")