$re = '/<\/?[^a\/].*?>/';
$str = '<img src="www.test.com">. Next words <a href="www.abc.com">abc</a><a></a><div></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);