// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<\/?[^a\/].*?>").unwrap();
let string = "<img src=\"www.test.com\">. Next words <a href=\"www.abc.com\">abc</a><a></a><div></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}