re = /<\/?[^a\/].*?>/
str = '<img src="www.test.com">. Next words <a href="www.abc.com">abc</a><a></a><div></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end