using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?),?\s*(\d{4}\D+)$";
string input = @"Bahnhofstrasse 1, 8001 Zürich
Bahnhofstrasse 1 8001 Zürich";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}