re = /^(.*?),?\s*(\d{4}\D+)$/m
str = 'Bahnhofstrasse 1, 8001 Zürich
Bahnhofstrasse 1 8001 Zürich'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end