$re = '/^(.*?),?\s*(\d{4}\D+)$/m';
$str = 'Bahnhofstrasse 1, 8001 Zürich
Bahnhofstrasse 1 8001 Zürich';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);