package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?),?\s*(\d{4}\D+)$`)
var str = `Bahnhofstrasse 1, 8001 Zürich
Bahnhofstrasse 1 8001 Zürich`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}