using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^!(\S+?)(?:(H\d+)|(E\d+)){0,2}$";
string input = @"!attackH5E4
=> (attack, H5, E4)
!attackE4H5
=> (attack, H5, E4)
!HHHHHHH5
=> (HHHHHH, H5, null)
!HHHHHHH5E4
=> (HHHHHH, H5, E4)
!HHHHHHH5E4
=> (HHHHHH, H5, E4)
!HHHHHHH5E4
=> (HHHHHH, H5, E4)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}