$re = '/^!(\S+?)(?:(H\d+)|(E\d+)){0,2}$/m';
$str = '!attackH5E4
=> (attack, H5, E4)
!attackE4H5
=> (attack, H5, E4)
!HHHHHHH5
=> (HHHHHH, H5, null)
!HHHHHHH5E4
=> (HHHHHH, H5, E4)
!HHHHHHH5E4
=> (HHHHHH, H5, E4)
!HHHHHHH5E4
=> (HHHHHH, H5, E4)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);