import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^!(\\S+?)(?:(H\\d+)|(E\\d+)){0,2}$";
final String string = "!attackH5E4\n"
+ " => (attack, H5, E4)\n"
+ "!attackE4H5\n"
+ " => (attack, H5, E4)\n"
+ "!HHHHHHH5\n"
+ " => (HHHHHH, H5, null)\n"
+ "!HHHHHHH5E4\n"
+ " => (HHHHHH, H5, E4)\n"
+ "!HHHHHHH5E4\n"
+ " => (HHHHHH, H5, E4)\n"
+ "!HHHHHHH5E4\n"
+ " => (HHHHHH, H5, E4)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}