re = /^!(\S+?)(?:(H\d+)|(E\d+)){0,2}$/m
str = '!attackH5E4
=> (attack, H5, E4)
!attackE4H5
=> (attack, H5, E4)
!HHHHHHH5
=> (HHHHHH, H5, null)
!HHHHHHH5E4
=> (HHHHHH, H5, E4)
!HHHHHHH5E4
=> (HHHHHH, H5, E4)
!HHHHHHH5E4
=> (HHHHHH, H5, E4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end