# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<!-- EN:\h*+(.*?)\h*-->\s*<\w+\.label>\K[^<>]+/$1/gm;t' <<< "<!-- EN: Text -->
<Tag1.label>Text2</Tag1.label>
<!-- EN: Text3 -->
<Tag2.label>Text4</Tag2.label>
"