$re = '~<!-- EN:\h*+(.*?)\h*-->\s*<\w+\.label>\K[^<>]+~m';
$str = '<!-- EN: Text -->
<Tag1.label>Text2</Tag1.label>
<!-- EN: Text3 -->
<Tag2.label>Text4</Tag2.label>
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;