import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!-- EN:\\h*+(.*?)\\h*-->\\s*<\\w+\\.label>\\K[^<>]+";
final String string = "<!-- EN: Text -->\n"
+ "<Tag1.label>Text2</Tag1.label>\n"
+ "<!-- EN: Text3 -->\n"
+ "<Tag2.label>Text4</Tag2.label>\n\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}