# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<!-- EN:\h*+(.*?)\h*-->\s*<\w+\.label>\K[^<>]+"
test_str = ("<!-- EN: Text -->\n"
"<Tag1.label>Text2</Tag1.label>\n"
"<!-- EN: Text3 -->\n"
"<Tag2.label>Text4</Tag2.label>\n\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.