const regex = /(?<=from )(.+?)(?=,| to)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=from )(.+?)(?=,| to)', 'gm')
const str = `Letter from author to recipient regarding topic 11-10-2018
Letter from author, regarding topic 10-11-2018`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}