re = /(?<=from )(.+?)(?=,| to)/m
str = 'Letter from author to recipient regarding topic 11-10-2018
Letter from author, regarding topic 10-11-2018'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end