import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]\\w{0,127}$";
final String string = "A\n"
+ "a\n"
+ "1\n"
+ "_\n\n"
+ "adfdff\n"
+ "_asfsdf\n"
+ "a_asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdf0\n\n"
+ "asdfffsd12354555342";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}