// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z]\w{0,127}$").unwrap();
let string = "A
a
1
_
adfdff
_asfsdf
a_asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdf0
asdfffsd12354555342";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}