$re = '/^[a-zA-Z]\w{0,127}$/m';
$str = 'A
a
1
_
adfdff
_asfsdf
a_asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdf0
asdfffsd12354555342';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);