import Foundation
let pattern = #"^[a-zA-Z]\w{0,127}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A
a
1
_
adfdff
_asfsdf
a_asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdfdsff9__asdf0
asdfffsd12354555342
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)