import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(https?:\\/\\/[\\w-]+(?:\\.[\\w]+)+(?:\\/[\\w-?=%&@$#_.+]+)*\\/?)(?:\\|((?:[^>])+))?>";
final String string = "<https://sky.slack.com/messages/2233/3333/33>\n\n"
+ "<https://sky.slack.com/>\n\n"
+ "<https://sky.slack.com/messages/@george.richmond/team/|@george.richmond>\n\n"
+ "<https://sky-2.slack.com/messages/@george.richmond/team/|@george.richmond>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}