re = /<(https?:\/\/[\w-]+(?:\.[\w]+)+(?:\/[\w-?=%&@$#_.+]+)*\/?)(?:\|((?:[^>])+))?>/
str = '<https://sky.slack.com/messages/2233/3333/33>
<https://sky.slack.com/>
<https://sky.slack.com/messages/@george.richmond/team/|@george.richmond>
<https://sky-2.slack.com/messages/@george.richmond/team/|@george.richmond>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end