// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<(https?:\/\/[\w-]+(?:\.[\w]+)+(?:\/[\w-?=%&@$#_.+]+)*\/?)(?:\|((?:[^>])+))?>").unwrap();
let string = "<https://sky.slack.com/messages/2233/3333/33>
<https://sky.slack.com/>
<https://sky.slack.com/messages/@george.richmond/team/|@george.richmond>
<https://sky-2.slack.com/messages/@george.richmond/team/|@george.richmond>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}