$re = '/<(https?:\/\/[\w-]+(?:\.[\w]+)+(?:\/[\w-?=%&@$#_.+]+)*\/?)(?:\|((?:[^>])+))?>/';
$str = '<https://sky.slack.com/messages/2233/3333/33>
<https://sky.slack.com/>
<https://sky.slack.com/messages/@george.richmond/team/|@george.richmond>
<https://sky-2.slack.com/messages/@george.richmond/team/|@george.richmond>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);