using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"releases\/download\/([\w.]+)\/FreeCAD_(?<build>[\w.]+)-Win";
string input = @"https://github.com/FreeCAD/FreeCAD/releases/download/0.19_pre/FreeCAD_0.19.24054-Win-Conda_vc14.x-x86_64.7z";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}